Login is not working
Incident Report for Sequoia
Resolved
This incident has been resolved.
Posted Jan 17, 2021 - 16:11 PST
Update
Sequoia Technical Team is aware of the service disruption with HRX and PX login issues and is actively investigating the incident. We will keep the users updated as we resolve the incident.
Posted Jan 17, 2021 - 15:30 PST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2021 - 15:28 PST
This incident affected: HRX and PX.