Provider Search functionality not working
Incident Report for Sequoia
Resolved
This incident has been resolved and Search functionality has been restored.
Posted Feb 18, 2021 - 08:07 PST
Identified
Anthem has identified the root cause and is working on the fix.
Posted Feb 16, 2021 - 09:05 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2021 - 08:23 PST
Investigating
Sequoia Technical Team is aware that the Search for Care (Find A Doctor, Find A Pharmacy, Find A Hospital) features in the Find Care tile are currently broken for Anthem and Empire subscribers. We are working with the vendors to restore the functionality as soon as possible.

For assistance please open a case in the My Advocate tile to connect with a dedicated Sequoia Advocate. Available M-F 8:30am-5pm PT
Posted Feb 16, 2021 - 08:18 PST
This incident affected: PX.