DNS issue
Incident Report for Sequoia
Resolved
The vendor has resolved the DNS issue and all Sequoia applications should be fully accessible.
Posted Mar 09, 2021 - 19:19 PST
Investigating
Sequoia Technical Team is aware of a DNS issue with one of our vendors. Due to this issue, you may have problems getting on the Sequoia mobile app, HRX, RTW and sequoia.com.

We are closely tracking our vendor's progress towards resolution and will update the status accordingly.
Posted Mar 09, 2021 - 17:35 PST
This incident affected: HRX and PX.