DNS resolution issue
Incident Report for Sequoia
Resolved
DNS issue has been resolved.
Posted Mar 10, 2021 - 16:41 PST
Investigating
Sequoia Technical Team is aware of a DNS issue with one of our vendors. Due to this issue, you may have problems getting on the Sequoia mobile app, HRX, RTW and sequoia.com.
Posted Mar 10, 2021 - 16:27 PST
This incident affected: HRX and PX.