Platform Under maintenance
Incident Report for Sequoia
Resolved
Issues with service disruption have been resolved and all services are now operational.
Posted May 13, 2022 - 22:19 PDT
Update
Sequoia Technical team has successfully completed the scheduled maintenance. All services are now operating normally.
Posted May 13, 2022 - 22:18 PDT
Update
We are continuing to investigate this issue.
Posted May 13, 2022 - 22:17 PDT
Investigating
Our platform is going through a maintenance work, and is expected to be down between 8:30PM PST to 9:30PM PST
Posted May 13, 2022 - 20:59 PDT
This incident affected: HRX and PX.