Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 22:45 PDT
Scheduled
As part of your drive to improve client and partner experience, we are applying changes to our Sequoia OS platform with the expected outcome to enhance performance. Due to this change, few features will have degraded performance for a limited period of time
Posted Oct 08, 2025 - 22:37 PDT
This scheduled maintenance affected: admin.sequoia.com and px.sequoia.com.