A fix has been implemented and all the components are functioning normally
Posted Apr 06, 2023 - 10:43 PDT
Update
We are continuing to investigate this issue.
Posted Apr 06, 2023 - 09:56 PDT
Investigating
Sequoia Technical Team is aware of the service disruption and is actively investigating the incident. We will keep the users updated as we resolve the incident.