Login Services down
Incident Report for Sequoia
Resolved
This incident has been resolved.
Posted May 03, 2022 - 10:13 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2022 - 10:02 PDT
Investigating
Sequoia Technical Team is aware of the service disruption and is actively investigating the incident. We will keep the users updated as we resolve the incident.
Posted May 03, 2022 - 10:01 PDT
This incident affected: HRX and PX.