Issues with service disruption have been resolved and all services are now operational.
Posted Nov 20, 2025 - 14:58 PST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2025 - 14:56 PST
Investigating
Sequoia Technical Team is aware of the service disruption and is actively investigating the incident. We will keep the users updated as we resolve the incident.
Posted Nov 20, 2025 - 14:20 PST
This incident affected: admin.sequoia.com and px.sequoia.com.