Workplace Service Disruption
Incident Report for Sequoia
Resolved
This incident has been resolved.
Posted Sep 02, 2021 - 13:30 PDT
Monitoring
Sequoia Technical team has implemented a fix. Fix has been verified and we will continue to monitor the results.
Posted Sep 02, 2021 - 12:22 PDT
Investigating
Sequoia Technical Team is aware of a Workplace issue that is impacting screening notifications and questionnaires. We are actively investigating the issue.
Posted Sep 02, 2021 - 11:16 PDT
This incident affected: HRX.