Sequoia Website Down due to technical incident
Incident Report for Sequoia
Resolved
The issue is found the issue and the fix is applied. The Websites are back to normal state.
Posted Jun 06, 2024 - 04:41 PDT
Investigating
Due to technical issues in our platform improvement activity, currently our HRX and PX portals are down. We are actively and urgently investigating the cause and working on a fix.
We will keep prompt update on the progress.
Posted Jun 06, 2024 - 04:28 PDT
This incident affected: HRX and PX.