Pharmacy Search
Incident Report for Sequoia
Resolved
We have implemented a workaround for the issue. A full fix will be implemented next week.
Posted Jul 23, 2021 - 14:28 PDT
Investigating
Sequoia Technical team is aware that Pharmacy Search functionality from the Sequoia mobile app is not working. We are investigating and working to restore the functionality as soon as possible.
Posted Jul 23, 2021 - 11:39 PDT
This incident affected: PX.